Dial Once

Xamarin SDK Documentation

This document will guide you through the integration of the Dial-Once SDK for Xamarin project.

Supported platforms

Installation & Setup

Table of Contents

  1. Introduction
  2. Prerequisites
  3. Android versions
  4. Installation

Introduction

This document will guide you through the creation of a sample application using the Dial-Once SDK library.

Prerequisites

Before you start, be sure you have the following prerequisites:

Android versions

The Dial-Once Android SDK supports Android 2.2+ (API Level 9) as the minSdkVersion, but it must be compiled using Android 6.0 (API Level 23) or above as the targetSdkVersion.

Installation

The best way to install the Dial-Once SDK for Xamarin is to use nuget packet manager

OR by modifying packages.config

<package id="DialOnce.Android" version="2.6.16" targetFramework="monoandroid60" requireReinstallation="true" />

Finally, add the following line to your Application class in the onCreate method.

DialOnce.Initialize("your_api_key_here");

Reporting Bugs or Feature Requests

To report a bug or make a feature request, send us a mail to publishers@dial-once.com