Dial Once

iOS SDK Documentation

Download

This document will guide you through the integration of the Dial-Once SDK for iOS.

Installation & Setup

Table of Contents

  1. Prerequisites
  2. Supported versions
  3. Installation

Prerequisites

Before you start, be sure you have the following prerequisites:

Supported versions

The Dial-Once SDK for iOS supports iOS 8.0+ as deployment target and we distribute SDK as DialOnce.framework

Installation

Cocoa Pods

Straightforward way To install the Dial-Once SDK for iOS is to use CocoaPods as package manager. Just add DialOnce pod to your target

target 'MyTargetApp' do
  ...
  pod 'DialOnce'
end

Finally, add the following line to your application delegate class in the application(_:didFinishLaunchingWithOptions:) method.

DialOnce.setupWithApiKey(AppDelegate.apiKey)
[DialOnce setupWithApiKey:DIALONCE_API_KEY];

Now your app is ready! For more information you can look at DialOnce.h

Carthage

Just add line to your Cartfile

github "dial-once/sdk-ios-releases" ~> 0.2.0